Bewegliche Feiertage mit Excel berechnen


Bewegliche Feiertage mit Excel berechnen

Bewegliche Feiertage mit Excel berechnen

Der Ostersonntag ist ein zentraler Feiertag, auf den sich viele andere beziehen bzw. daraus abgeleitet werden können. Den Ostersonntag können Sie mit der folgenden Formel ermitteln:

=DM((TAG(MINUTE(A1/38)/2+55)&".4."&A1)/7;)*7-6

Bei der Formel wird davon ausgegangen, dass die jeweilige Jahreszahl in der Zelle A1 steht. Die Formel gibt ein Datum als Zahl zurück. Bitte stellen Sie daher als Zahlenformat ein Datumsformat für die Ergebniszelle ein.

 

Die folgenden Feiertage können Sie nun folgendermaßen aus dem Ostersonntag ableiten:

  • Rosenmontag = Ostersonntag - 48
  • Aschermittwoch = Ostersonntag – 46
  • Karfreitag = Ostersonntag -2
  • Ostersamstag = Ostersonntag - 1
  • Ostermontag = Ostersonntag + 1
  • Christi Himmelfahrt = Ostersonntag + 39
  • Pfingstsamstag = Ostersonntag + 48
  • Pfingstsonntag = Ostersonntag + 49
  • Pfingstmontag = Ostersonntag + 50
  • Fronleichnam = Ostersonntag + 60

Die folgenden Feiertage werden von Weihnachten abgeleitet. Die Formeln gehen davon aus, dass in der Zelle A1 die Jahreszahl steht.

  • Volkstrauertag =DATUM(A1;12;25)-WOCHENTAG(DATUM(A1;12;25);2)-35
  • Buss- und Bettag =DATUM(A1;12;25)-WOCHENTAG(DATUM(A1;12;25);2)-32
  • Totensonntag =DATUM(A1;12;25)-WOCHENTAG(DATUM(A1;12;25);2)-28
  • 1. Advent =DATUM(A1;12;25)-WOCHENTAG(DATUM(A1;12;25);2)-21 
  • 2. Advent =DATUM(A1;12;25)-WOCHENTAG(DATUM(A1;12;25);2)-14
  • 3. Advent =DATUM(A1;12;25)-WOCHENTAG(DATUM(A1;12;25);2)-7
  • 4. Advent =DATUM(A1;12;25)-WOCHENTAG(DATUM(A1;12;25);2) 

Sonstige Feiertage

  • Erntedankfest = =DATUM(A1;10;1)+7-WOCHENTAG(DATUM(A1;10;1);2)
  • Muttertag = =WENN(WOCHENTAG(DATUM(A1;5;1);1)=1;(DATUM(A1;5;1)+7);(DATUM(A1;5;1)-WOCHENTAG(DATUM(A1;5;1)))+15)