Letzte benutzte Zeile in einem Bereich ermitteln


Letzte benutzte Zeile in einem Bereich ermitteln

Letzte benutzte Zeile in einem Bereich mit Formel ermitteln

Wenn Sie in einem bestimmten Bereich die letzte benutzte Zeile ermitteln wollen, dann können Sie dies mit einer Formel ermitteln. Wenn Sie z. B. den Bereich A1:B100 nach der letzten benutzen Zeile durchsuchen wollen, dann können Sie dies mit folgenden Formel erreichen.

=SUMMENPRODUKT(MAX((A1:B100<>"")*ZEILE(1:100)))

Bitte beachten Sie, dass die Formel nicht in einer Zelle innerhalb des angegebenen Bereichs (A1:B100) stehen darf. Sie erhalten sonst einen Zirkelbezug.

 

Abbildung Letzte benutzte Zeile im Bereich A1:B100 ermitteln

In der obigen Abbildung wird in der Zelle C1 der Bereich A1:B100 nach der letzten benutzten Zeile durchsucht. Die Formel ermittelt die Zeile 12 als Ergebnis, da der letzte Eintrag in diesem Bereich in der Zelle B12 vorgenommen worden ist.

Wenn Sie die Zeile der letzten benutzten Zelle in einem Bereich auf einem anderen Tabellenblatt der gleichen Arbeitsmappe ermitteln (z.B. Tabelle2), dann müssen Sie die obige Formel nur geringfügig verändern.

=SUMMENPRODUKT(MAX((Tabelle2!A1:B100<>"")*ZEILE(1:100)))

Hinweis:

Bitte beachten Sie, dass wenn eine Zelle im angegebenen Bereich, der durchsucht wird, einen Fehlerwert erhält, dann liefern die obigen Formel ebenfalls einen Fehlerwert.